Contar elementos que cumplan una condición o varias – Spreadsheets Tips

Contar los que cumplan un solo criterio

Supongamos la siguiente situación. Tenemos una tabla con datos y en una de las columnas tenemos 2 posibles valores, si o no, y queremos contar cuantas veces esta el valor si y cuantas esta el valor no. Ademas queremos que este total se actualize según se introduzcan datos en esa columna.

Para realizar este calculo en Excel o Numbers o LibreOffice Calc utilizaremos la función CONTAR.SI

= CONTAR.SI(rango;valor)

Si por ejemplo queremos saber cuantas veces se ha escrito el valor ‘Si’ en la columna A escribiremos:

= CONTAR.SI(A:A; "Si")

En LibreOffice Calc la función es la misma, con una salvedad, la cual puede resultar un poco incomoda, no podemos seleccionar la columna entera y tenemos que definir el rango. Por lo demás la formula es igual.

En Numbers la función es tambien igual pero en el rango si seleccionamos la columna A solo hace falta poner A.

Importante: Hay que tener en cuenta las dobles comillas para encerrar textos literales y el ‘;’ para separar los parámetros.

En el caso que estemos utilizando Google Spreadsheets, hay que tener en cuenta que las formulas no han sido traducidas al castellano, por lo tanto tenemos que usarlo como si estuviéramos usando el Excel en Ingles y usaríamos la función COUNTIF

= COUNTIF(rango, valor)

Para saber cuantas veces se ha escrito el valor ‘Si’ en la columna A

= COUNTIF(A:A, "Si")

Una de las diferencias entre las versiones de los programas de hojas de calculo en Español o en ingles es que en las versiones inglesas usan la coma (,) como separador de parámetros en la función.

 

Contar los que cumplan mas de un criterio

La función anterior solo nos permite buscar en una columna un criterio, pero ¿y si necesitamos contar los que cumplan dos criterios? En ese caso si estamos utilizando Excel, Numbers o Libreoffice Calc utilizaremos la función: CONTAR.SI.CONJUNTO()

= CONTAR.SI.CONJUNTO(rango1;criterio1;rango2;criterio2;...)

Si tenemos la columna A con valores Si o No y la columna B con valores Si o No y queremos saber cuantas veces si el valor de la A es Si el valor de la B es Si

= CONTAR.SI.CONJUNTO(A:A;"Si";B:B;"Si")

En el caso de Google Spreadsheets no existe una función equivalente y para obtener el resultado tenemos que utilizar la función ARRAYFORMULA con el COUNTIF anidado.

= ARRAYFORMULA( COUNTIF(rango1&rango2&..., criterio1&criterio2&...) )

De tal manera que para obtener nuestro resultado tendríamos que hacer lo siguiente

= ARRAYFORMULA( countif(A:A&B:B, "Si"&"Si") )

 

Anuncios

Un pensamiento en “Contar elementos que cumplan una condición o varias – Spreadsheets Tips”

  1. Tengo una consulta, un formula que no puedo sacar.
    Tengo 3 diferentes importes(es para traer valores en una tabla de una prepaga), segun la edad. Por ejemplo:
    Si la persona tiene edad entre 1 y 25 años (la edad de la persona ya esta en una celda por ej H6) traer el valor de una celda(ej C1), si tiene entre 26 y 35 años traer el valor de C2 y si tiene entre 36 y 64 años el valor de C3. Probe si y si anidada, pero me tira error.
    Y otra consulta relacionada, Si aparte de la edad, hay otro condicionante, osea si tiene un plan ej: 210 (ej:G5) traer los valores de entre las celdas C1 y C3 -condicionadas segun la edad(primera consulta), si tiene un plan 310 traer los valores de entre D1 y D3 y luego el condicionamiento de edad y si tiene un plan 410 los valores entre E1 y E3, y luego el condicionante de edad, se puede?
    Se agradece desde ya cualquier ayuda posible.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s